CVE-2024-31452
High
Description
OpenFGA is a high-performance and flexible authorization/permission engine. Some end users of OpenFGA v1.5.0 or later are vulnerable to authorization bypass when calling Check or ListObjects APIs. You are very likely affected if your model involves exclusion (e.g. `a but not b`) or intersection (e.g. `a and b`). This vulnerability is fixed in v1.5.3.
SeverityHigh
CVSS8.1
Exploit probability—
ProductOpenfga
PublishedApr 16, 2024
First seenApr 16, 2024
Weakness typeCWE-863Incorrect authorization
How to fix
Update
- openfga openfga1.5.3 or later
- github.com/openfga/openfga1.5.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| openfga openfga | 1.5.0 ≤ v < 1.5.3 | 1.5.3 |
| github.com/openfga/openfgaGo | 1.5.0 ≤ v < 1.5.3 | 1.5.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.