CVE-2024-31860
Medium
Description
Improper Input Validation vulnerability in Apache Zeppelin. By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access. This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Apache Zeppelin
PublishedApr 9, 2024
First seenApr 9, 2024
Weakness typeCWE-22Path traversal
How to fix
Update
- apache zeppelin0.11.0 or later
- org.apache.zeppelin:zeppelin-server0.11.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache zeppelin | 0.9.0 ≤ v < 0.11.0 | 0.11.0 |
| org.apache.zeppelin:zeppelin-serverMaven | 0.9.0 ≤ v < 0.11.0 | 0.11.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.