CVE-2024-31863
Medium
Description
Authentication Bypass by Spoofing vulnerability by replacing to exsiting notes in Apache Zeppelin.This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.
SeverityMedium
CVSS5.3
Exploit probability—
Product
Apache Zeppelin
PublishedApr 9, 2024
First seenApr 9, 2024
Weakness typeCWE-290CWE-290
How to fix
Update
- org.apache.zeppelin:zeppelin-server0.11.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache zeppelin | 0.10.1 | — |
| org.apache.zeppelin:zeppelin-serverMaven | 0.10.1 ≤ v < 0.11.0 | 0.11.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.