CVE-2024-31864

Critical

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin. The attacker can inject sensitive configuration or malicious code when connecting MySQL database via JDBC driver. This issue affects Apache Zeppelin: before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Zeppelin
PublishedApr 9, 2024
First seenApr 9, 2024

How to fix

Update
  • apache zeppelin0.11.1 or later
  • org.apache.zeppelin:zeppelin-jdbc0.11.1 or later

Affected products

ProductAffected versionsFixed in
apache zeppelinv < 0.11.10.11.1
org.apache.zeppelin:zeppelin-jdbcMavenv < 0.11.10.11.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.