CVE-2024-31865

Medium

Description

Improper Input Validation vulnerability in Apache Zeppelin. The attackers can call updating cron API with invalid or improper privileges so that the notebook can run with the privileges. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Zeppelin
PublishedApr 9, 2024
First seenApr 9, 2024

How to fix

Update
  • apache zeppelin0.11.1 or later
  • org.apache.zeppelin:zeppelin-server0.11.1 or later

Affected products

ProductAffected versionsFixed in
apache zeppelin0.8.2 ≤ v < 0.11.10.11.1
org.apache.zeppelin:zeppelin-serverMaven0.8.2 ≤ v < 0.11.10.11.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.