CVE-2024-31866
Critical
Description
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Zeppelin
PublishedApr 9, 2024
First seenApr 9, 2024
Weakness typeCWE-116CWE-116
How to fix
Update
- apache zeppelin0.11.1 or later
- org.apache.zeppelin:zeppelin-interpreter0.11.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache zeppelin | 0.8.2 ≤ v < 0.11.1 | 0.11.1 |
| org.apache.zeppelin:zeppelin-interpreterMaven | 0.8.2 ≤ v < 0.11.1 | 0.11.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.