CVE-2024-3190

Medium

Description

The Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's text field widget in all versions up to, and including, 1.5.107 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Please note that this vulnerability is different in that the issue stems from an external template. It appears that older version may also be patched due to this, however, we are choosing 1.5.108 as the patched version since that is the most recent version containing as known patch.

SeverityMedium
CVSS5.4
Exploit probability—
ProductUnlimited-elements Unlimited Elements For Elementor
PublishedMay 30, 2024
First seenMay 30, 2024

How to fix

Update
  • unlimited-elements unlimited_elements_for_elementor1.5.108 or later

Affected products

ProductAffected versionsFixed in
unlimited-elements unlimited_elements_for_elementorv < 1.5.1081.5.108

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-3190 · Unlimited-elements Unlimited Elements For Elementor · Dark Radar