CVE-2024-31979

Medium

Description

Server-Side Request Forgery (SSRF) vulnerability in Apache StreamPipes during installation process of pipeline elements. Previously, StreamPipes allowed users to configure custom endpoints from which to install additional pipeline elements. These endpoints were not properly validated, allowing an attacker to get StreamPipes to send an HTTP GET request to an arbitrary address. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.

SeverityMedium
CVSS4.3
Exploit probability—
ProductApache Streampipes
PublishedJul 17, 2024
First seenJul 17, 2024

How to fix

Update
  • apache streampipes0.95.0 or later
  • org.apache.streampipes:streampipes-parent0.95.0 or later
  • streampipes0.95.0 or later

Affected products

ProductAffected versionsFixed in
apache streampipesv < 0.95.00.95.0
org.apache.streampipes:streampipes-parentMavenv < 0.95.00.95.0
streampipesPyPIv < 0.95.00.95.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.