CVE-2024-32004
Description
Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.
How to fix
- git-scm git2.39.4, 2.40.2, 2.42.2, 2.43.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| git-scm git | v < 2.39.4, 2.40.0 ≤ v < 2.40.2, 2.42.0 ≤ v < 2.42.2, 2.43.0 ≤ v < 2.43.4, 2.41.0, 2.44.0, 2.45.0 | 2.39.4, 2.40.2, 2.42.2, 2.43.4 |
| fedoraproject fedora | 40 | — |
| debian debian_linux | 10.0, 11.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.