CVE-2024-3203

High

Description

A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.

SeverityHigh
CVSS7.3
Exploit probability—
ProductC-blosc2
PublishedApr 2, 2024
First seenApr 2, 2024
Weakness typeCWE-122CWE-122

How to fix

Affected products

ProductAffected versionsFixed in
blosc c-blosc2v ≤ 2.13.2—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.