CVE-2024-3204

High

Description

A vulnerability has been found in c-blosc2 up to 2.13.2 and classified as critical. Affected by this vulnerability is the function ndlz4_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz4x4.c. The manipulation leads to heap-based buffer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-259051.

SeverityHigh
CVSS7.3
Exploit probability—
ProductC-blosc2
PublishedApr 2, 2024
First seenApr 2, 2024
Weakness typeCWE-122CWE-122

How to fix

Affected products

ProductAffected versionsFixed in
blosc c-blosc2v ≤ 2.13.2—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.