CVE-2024-32077
Medium
Description
Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs. Users are recommended to upgrade to version 2.9.1, which fixes this issue.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Apache Airflow
PublishedMay 14, 2024
First seenMay 14, 2024
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- apache-airflow2.9.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache airflow | 2.9.0 | — |
| apache-airflowPyPI | 2.9.0 ≤ v < 2.9.1, v ≤ 2.9.0-NA | 2.9.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.