CVE-2024-32474

High

Description

Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.

SeverityHigh
CVSS7.3
Exploit probability—
ProductSentry
PublishedApr 18, 2024
First seenApr 18, 2024

How to fix

Update
  • sentry sentry24.4.1 or later
  • sentry24.4.1 or later

Affected products

ProductAffected versionsFixed in
sentry sentry24.3.0 ≤ v < 24.4.124.4.1
sentryPyPI24.3.0 ≤ v < 24.4.124.4.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.