CVE-2024-32638

Medium

Description

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0. Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.

SeverityMedium
CVSS6.3
Exploit probability—
ProductApache Apisix
PublishedMay 2, 2024
First seenMay 2, 2024
Weakness typeCWE-444CWE-444

How to fix

Affected products

ProductAffected versionsFixed in
apache apisix3.8.0, 3.9.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.