CVE-2024-33893

Medium

Description

Cosy+ devices running a firmware 21.x below 21.2s10 or a firmware 22.x below 22.1s3 are vulnerable to XSS when displaying the logs due to improper input sanitization. This is fixed in version 21.2s10 and 22.1s3.

SeverityMedium
CVSS6.1
Exploit probability—
ProductHms-networks Ewon Cosy\+ Firmware
PublishedAug 2, 2024
First seenAug 2, 2024

How to fix

Sources list no fixed version or patch link for this vulnerability.

Affected products

ProductAffected versionsFixed in
hms-networks ewon_cosy\+_firmware21.0 ≤ v ≤ 21.2s10, 22.0 ≤ v ≤ 22.1s3—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.