CVE-2024-34693
Description
Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table.This issue affects Apache Superset: before 3.1.3 and version 4.0.0 Users are recommended to upgrade to version 4.0.1 or 3.1.3, which fixes the issue.
How to fix
- apache superset3.1.3, 4.0.1 or later
- apache-superset3.1.3, 4.0.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache superset | v < 3.1.3, 4.0.0 ≤ v < 4.0.1 | 3.1.3, 4.0.1 |
| apache-supersetPyPI | v < 3.1.3, 4.0.0 ≤ v < 4.0.1 | 3.1.3, 4.0.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.