CVE-2024-34715

Low

Description

Fides is an open-source privacy engineering platform. The Fides webserver requires a connection to a hosted PostgreSQL database for persistent storage of application data. If the password used by the webserver for this database connection includes special characters such as `@` and `$`, webserver startup fails and the part of the password following the special character is exposed in webserver error logs. This is caused by improper escaping of the SQLAlchemy password string. As a result users are subject to a partial exposure of hosted database password in webserver logs. The vulnerability has been patched in Fides version `2.37.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no known workarounds for this vulnerability.

SeverityLow
CVSS2.3
Exploit probability—
ProductEthyca Fides
PublishedMay 29, 2024
First seenMay 29, 2024

How to fix

Update
  • ethyca fides2.37.0 or later
  • ethyca-fides2.37.0 or later

Affected products

ProductAffected versionsFixed in
ethyca fidesv < 2.37.02.37.0
ethyca-fidesPyPIv < 2.37.02.37.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.