CVE-2024-34914
Medium
Description
php-censor v2.1.4 and fixed in v.2.1.5 was discovered to utilize a weak hashing algorithm for its remember_key value. This allows attackers to bruteforce to bruteforce the remember_key value to gain access to accounts that have checked "remember me" when logging in.
SeverityMedium
CVSS5.3
Exploit probability—
ProductPhp-censor/php-censor
PublishedMay 14, 2024
First seenMay 14, 2024
Weakness typeCWE-328CWE-328
How to fix
Update
- php-censor/php-censor2.1.5, 2.0.13 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| php-censor/php-censorPackagist | 2.1.0 ≤ v < 2.1.5, v < 2.0.13 | 2.1.5, 2.0.13 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.