CVE-2024-35220
High
Description
@fastify/session is a session plugin for fastify. Requires the @fastify/cookie plugin. When restoring the cookie from the session store, the `expires` field is overriden if the `maxAge` field was set. This means a cookie is never correctly detected as expired and thus expired sessions are not destroyed. This vulnerability has been patched 10.8.0.
SeverityHigh
CVSS7.4
Exploit probability—
Product@fastify/session
PublishedMay 21, 2024
First seenMay 21, 2024
Weakness typeCWE-613CWE-613
How to fix
Update
- @fastify/session10.9.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| @fastify/sessionnpm | v < 10.9.0 | 10.9.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.