CVE-2024-35230
Description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. In affected versions the welcome and about page includes version and revision information about the software in use (including library and components used). This information is sensitive from a security point of view because it allows software used by the server to be easily identified. This issue has been patched in version 2.26.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
How to fix
- osgeo geoserver2.25.1 or later
- org.geoserver.web:gs-web-app2.25.1 or later
- org.geoserver.web:gs-web-core2.25.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| osgeo geoserver | 2.0.0 ≤ v < 2.25.1 | 2.25.1 |
| org.geoserver.web:gs-web-appMaven | 2.0.0 ≤ v < 2.25.1 | 2.25.1 |
| org.geoserver.web:gs-web-coreMaven | 2.0.0 ≤ v < 2.25.1 | 2.25.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.