CVE-2024-3584

High

Description

qdrant/qdrant version 1.9.0-dev is vulnerable to path traversal due to improper input validation in the `/collections/{name}/snapshots/upload` endpoint. By manipulating the `name` parameter through URL encoding, an attacker can upload a file to an arbitrary location on the system, such as `/root/poc.txt`. This vulnerability allows for the writing and overwriting of arbitrary files on the server, potentially leading to a full takeover of the system. The issue is fixed in version 1.9.0.

SeverityHigh
CVSS7.5
Exploit probability—
ProductQdrant
PublishedMay 30, 2024
First seenMay 30, 2024

How to fix

Update
  • qdrant qdrant1.9.0 or later

Affected products

ProductAffected versionsFixed in
qdrant qdrantv < 1.9.01.9.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.