CVE-2024-36113

Medium

Description

Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch, version 3.3.0.beta3 on the `beta` branch, and version 3.3.0.beta4-dev on the `tests-passed` branch, a rogue staff user could suspend other staff users preventing them from logging in to the site. The issue is patched in version 3.2.3 on the `stable` branch, version 3.3.0.beta3 on the `beta` branch, and version 3.3.0.beta4-dev on the `tests-passed` branch. No known workarounds are available.

SeverityMedium
CVSS4.9
Exploit probability—
ProductDiscourse
PublishedJul 3, 2024
First seenJul 3, 2024

How to fix

Update
  • discourse discourse3.2.3, 3.3.0 or later

Affected products

ProductAffected versionsFixed in
discourse discoursev < 3.2.3, v < 3.3.0, 3.3.03.2.3, 3.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.