CVE-2024-36268

Critical

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong. This issue affects Apache InLong: from 1.10.0 through 1.12.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.13.0 or cherry-pick [1] to solve it. [1]  https://github.com/apache/inlong/pull/10251

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Inlong
PublishedAug 2, 2024
First seenAug 2, 2024

How to fix

Update
  • apache inlong1.13.0 or later
  • org.apache.inlong:tubemq-core1.13.0 or later

Affected products

ProductAffected versionsFixed in
apache inlong1.10.0 ≤ v < 1.13.01.13.0
org.apache.inlong:tubemq-coreMaven1.10.0 ≤ v < 1.13.01.13.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.