CVE-2024-36471

High

Description

Import functionality is vulnerable to DNS rebinding attacks between verification and processing of the URL.  Project administrators can run these imports, which could cause Allura to read from internal services and expose them. This issue affects Apache Allura from 1.0.1 through 1.16.0. Users are recommended to upgrade to version 1.17.0, which fixes the issue. If you are unable to upgrade, set "disable_entry_points.allura.importers = forge-tracker, forge-discussion" in your .ini config file.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Allura
PublishedJun 10, 2024
First seenJun 10, 2024

How to fix

Update
  • apache allura1.17.0 or later

Affected products

ProductAffected versionsFixed in
apache allura1.0.1 ≤ v < 1.17.01.17.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.