CVE-2024-36522
Critical
Description
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Wicket
PublishedJul 12, 2024
First seenJul 12, 2024
Weakness typeCWE-74Injection
How to fix
Update
- apache wicket8.16.0, 9.18.0 or later
- org.apache.wicket:wicket-util10.1.0, 9.18.0, 8.16.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache wicket | 8.0.0 ≤ v < 8.16.0, 9.0.0 ≤ v < 9.18.0, 10.0.0 | 8.16.0, 9.18.0 |
| org.apache.wicket:wicket-utilMaven | 10.0.0-M1 ≤ v < 10.1.0, 9.0.0 ≤ v < 9.18.0, 8.0.0 ≤ v < 8.16.0 | 10.1.0, 9.18.0, 8.16.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.