CVE-2024-37313
Description
Nextcloud server is a self hosted personal cloud system. Under some circumstance it was possible to bypass the second factor of 2FA after successfully providing the user credentials. It is recommended that the Nextcloud Server is upgraded to 26.0.13, 27.1.8 or 28.0.4 and Nextcloud Enterprise Server is upgraded to 21.0.9.17, 22.2.10.22, 23.0.12.17, 24.0.12.13, 25.0.13.8, 26.0.13, 27.1.8 or 28.0.4.
How to fix
- nextcloud nextcloud_server21.0.9.17, 22.2.10.22, 23.0.12.17, 24.0.12.13, 25.0.13.8, 26.0.13, 27.1.8, 28.0.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_server | 21.0.0 ≤ v < 21.0.9.17, 22.0.0 ≤ v < 22.2.10.22, 23.0.0 ≤ v < 23.0.12.17, 24.0.0 ≤ v < 24.0.12.13, 25.0.0 ≤ v < 25.0.13.8, 26.0.0 ≤ v < 26.0.13, 27.0.0 ≤ v < 27.1.8, 28.0.0 ≤ v < 28.0.4 | 21.0.9.17, 22.2.10.22, 23.0.12.17, 24.0.12.13, 25.0.13.8, 26.0.13, 27.1.8, 28.0.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.