CVE-2024-37389
Description
Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.
How to fix
- apache nifi1.27.0 or later
- org.apache.nifi:nifi-web-ui1.27.0, 2.0.0-M4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache nifi | 1.10.0 ≤ v < 1.27.0, 2.0.0 | 1.27.0 |
| org.apache.nifi:nifi-web-uiMaven | 1.10.0 ≤ v < 1.27.0, 2.0.0-M1 ≤ v < 2.0.0-M4 | 1.27.0, 2.0.0-M4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.