CVE-2024-3761

High

Description

In lunary-ai/lunary version 1.2.2, the DELETE endpoint located at `packages/backend/src/api/v1/datasets` is vulnerable to unauthorized dataset deletion due to missing authorization and authentication mechanisms. This vulnerability allows any user, even those without a valid token, to delete a dataset by sending a DELETE request to the endpoint. The issue was fixed in version 1.2.8. The impact of this vulnerability is significant as it permits unauthorized users to delete datasets, potentially leading to data loss or disruption of service.

SeverityHigh
CVSS7.5
Exploit probability—
ProductLunary
PublishedMay 20, 2024
First seenMay 20, 2024

How to fix

Update
  • lunary lunary1.2.8 or later

Affected products

ProductAffected versionsFixed in
lunary lunaryv < 1.2.81.2.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.