CVE-2024-37884
Low
Description
Nextcloud Server is a self hosted personal cloud system. A malicious user was able to send delete requests for old versions of files they only got shared with read permissions. It is recommended that the Nextcloud Server is upgraded to 26.0.12 or 27.1.7 or 28.0.3 and that the Nextcloud Enterprise Server is upgraded to 26.0.12 or 27.1.7 or 28.0.3.
SeverityLow
CVSS3.5
Exploit probability—
Product
Nextcloud Server
PublishedJun 14, 2024
First seenJun 14, 2024
Weakness typeCWE-284Improper access control
How to fix
Update
- nextcloud nextcloud_server25.0.13.7, 26.0.13, 27.1.8, 28.0.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_server | 25.0.0 ≤ v < 25.0.13.7, 26.0.0 ≤ v < 26.0.13, 27.0.0 ≤ v < 27.1.8, 28.0.0 ≤ v < 28.0.4 | 25.0.13.7, 26.0.13, 27.1.8, 28.0.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.