CVE-2024-37899

Critical

Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When an admin disables a user account, the user's profile is executed with the admin's rights. This allows a user to place malicious code in the user profile before getting an admin to disable the user account. To reproduce, as a user without script nor programming rights, edit the about section of your user profile and add `{{groovy}}services.logging.getLogger("attacker").error("Hello from Groovy!"){{/groovy}}`. As an admin, go to the user profile and click the "Disable this account" button. Then, reload the page. If the logs show `attacker - Hello from Groovy!` then the instance is vulnerable. This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0. Users are advised to upgrade. There are no known workarounds for this vulnerability. ### Workarounds We're not aware of any workaround except upgrading. ### References * https://jira.xwiki.org/browse/XWIKI-21611 * https://github.com/xwiki/xwiki-platform/commit/f89c8f47fad6e5cc7e68c69a7e0acde07f5eed5a

SeverityCritical
CVSS9.0
Exploit probability—
ProductXwiki
PublishedJun 20, 2024
First seenJun 20, 2024

How to fix

Update
  • xwiki xwiki14.10.21, 15.5.5, 15.10.6 or later
  • org.xwiki.platform:xwiki-platform-oldcore14.10.21, 15.5.5, 15.10.6, 16.0.0 or later

Affected products

ProductAffected versionsFixed in
xwiki xwiki13.10.3 ≤ v < 14.10.21, 15.0 ≤ v < 15.5.5, 15.6 ≤ v < 15.10.6, 13.4.7, 13.5, 16.0.014.10.21, 15.5.5, 15.10.6
org.xwiki.platform:xwiki-platform-oldcoreMaven13.4.7 ≤ v < 14.10.21, 13.10.3 ≤ v < 14.10.21, 15.0-rc-1 ≤ v < 15.5.5, 15.6-rc-1 ≤ v < 15.10.6, 16.0.0-rc-1 ≤ v < 16.0.014.10.21, 15.5.5, 15.10.6, 16.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.