CVE-2024-38286

High

Description

Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.13 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.35 through 8.5.100 and 7.0.92 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25, or 9.0.90, which fixes the issue. Apache Tomcat, under certain configurations on any platform, allows an attacker to cause an OutOfMemoryError by abusing the TLS handshake process.

SeverityHigh
CVSS8.6
Exploit probability—
ProductApache Tomcat
PublishedNov 7, 2024
First seenNov 7, 2024

How to fix

Update
  • apache tomcat9.0.90, 10.1.25 or later
  • org.apache.tomcat:tomcat-coyote11.0.0-M21, 10.1.25, 9.0.90 or later
  • org.apache.tomcat.embed:tomcat-embed-core11.0.0-M21, 10.1.25, 9.0.90 or later

Affected products

ProductAffected versionsFixed in
apache tomcat9.0.13 ≤ v < 9.0.90, 10.1.1 ≤ v < 10.1.25, 10.1.0, 11.0.09.0.90, 10.1.25
netapp ontap_tools9, 10—
org.apache.tomcat:tomcat-coyoteMaven11.0.0-M1 ≤ v < 11.0.0-M21, 10.1.0-M1 ≤ v < 10.1.25, 9.0.13 ≤ v < 9.0.90, 8.5.35 ≤ v ≤ 8.5.100, 7.0.92 ≤ v ≤ 7.0.10911.0.0-M21, 10.1.25, 9.0.90
org.apache.tomcat.embed:tomcat-embed-coreMaven11.0.0-M1 ≤ v < 11.0.0-M21, 10.1.0-M1 ≤ v < 10.1.25, 9.0.13 ≤ v < 9.0.90, 8.5.35 ≤ v ≤ 8.5.100, 7.0.92 ≤ v ≤ 7.0.10911.0.0-M21, 10.1.25, 9.0.90

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.