CVE-2024-3829

Critical

Description

qdrant/qdrant version 1.9.0-dev is vulnerable to arbitrary file read and write during the snapshot recovery process. Attackers can exploit this vulnerability by manipulating snapshot files to include symlinks, leading to arbitrary file read by adding a symlink that points to a desired file on the filesystem and arbitrary file write by including a symlink and a payload file in the snapshot's directory structure. This vulnerability allows for the reading and writing of arbitrary files on the server, which could potentially lead to a full takeover of the system. The issue is fixed in version v1.9.0.

SeverityCritical
CVSS9.1
Exploit probability—
ProductQdrant
PublishedJun 3, 2024
First seenJun 3, 2024

How to fix

Update
  • qdrant qdrant1.9.0 or later
  • qdrant-client1.9.0 or later

Affected products

ProductAffected versionsFixed in
qdrant qdrantv < 1.9.01.9.0
qdrant-clientPyPIv < 1.9.01.9.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.