CVE-2024-38311

Medium

Description

Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.8, from 10.0.0 through 10.0.3. Users are recommended to upgrade to version 9.2.9 or 10.0.4, which fixes the issue.

SeverityMedium
CVSS6.3
Exploit probability—
ProductApache Traffic Server
PublishedMar 6, 2025
First seenMar 6, 2025

How to fix

Update
  • apache traffic_server9.2.9, 10.0.4 or later

Affected products

ProductAffected versionsFixed in
apache traffic_server9.0.0 ≤ v < 9.2.9, 10.0.0 ≤ v < 10.0.49.2.9, 10.0.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.