CVE-2024-38357
Description
TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed. Users are advised to upgrade. There are no known workarounds for this vulnerability.
How to fix
- tinymce5.11.0, 6.8.4, 7.2.0 or later
- TinyMCE5.11.0, 6.8.4, 7.2.0 or later
- tinymce/tinymce5.11.0, 6.8.4, 7.2.0 or later
- django-tinymce4.1.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| tinymcenpm | v < 5.11.0, 6.0.0 ≤ v < 6.8.4, 7.0.0 ≤ v < 7.2.0 | 5.11.0, 6.8.4, 7.2.0 |
| TinyMCENuGet | v < 5.11.0, 6.0.0 ≤ v < 6.8.4, 7.0.0 ≤ v < 7.2.0 | 5.11.0, 6.8.4, 7.2.0 |
| tinymce/tinymcePackagist | v < 5.11.0, 6.0.0 ≤ v < 6.8.4, 7.0.0 ≤ v < 7.2.0 | 5.11.0, 6.8.4, 7.2.0 |
| django-tinymcePyPI | v < 4.1.0 | 4.1.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.