CVE-2024-38379
Medium
Description
Apache Allura's neighborhood settings are vulnerable to a stored XSS attack. Only neighborhood admins can access these settings, so the scope of risk is limited to configurations where neighborhood admins are not fully trusted. This issue affects Apache Allura: from 1.4.0 through 1.17.0. Users are recommended to upgrade to version 1.17.1, which fixes the issue.
SeverityMedium
CVSS4.8
Exploit probability—
Product
Apache Allura
PublishedJun 22, 2024
First seenJun 22, 2024
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- apache allura1.17.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache allura | 1.4.0 ≤ v < 1.17.1 | 1.17.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.