CVE-2024-38473
High
Description
Encoding problem in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows request URLs with incorrect encoding to be sent to backend services, potentially bypassing authentication via crafted requests. Users are recommended to upgrade to version 2.4.60, which fixes this issue.
SeverityHigh
CVSS8.1
Exploit probability—
Product
Apache Http Server
PublishedJul 1, 2024
First seenJul 1, 2024
Weakness typeCWE-116CWE-116
How to fix
Update
- apache http_server2.4.60 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache http_server | 2.4.0 ≤ v < 2.4.60 | 2.4.60 |
| netapp ontap | 9 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.