CVE-2024-38513

Critical

Description

Fiber is an Express-inspired web framework written in Go A vulnerability present in versions prior to 2.52.5 is a session middleware issue in GoFiber versions 2 and above. This vulnerability allows users to supply their own session_id value, resulting in the creation of a session with that key. If a website relies on the mere presence of a session for security purposes, this can lead to significant security risks, including unauthorized access and session fixation attacks. All users utilizing GoFiber's session middleware in the affected versions are impacted. The issue has been addressed in version 2.52.5. Users are strongly encouraged to upgrade to version 2.52.5 or higher to mitigate this vulnerability. Users who are unable to upgrade immediately can apply the following workarounds to reduce the risk: Either implement additional validation to ensure session IDs are not supplied by the user and are securely generated by the server, or regularly rotate session IDs and enforce strict session expiration policies.

SeverityCritical
CVSS10.0
Exploit probability—
ProductFiber
PublishedJul 1, 2024
First seenJul 1, 2024
Weakness typeCWE-384CWE-384

How to fix

Update
  • gofiber fiber2.52.5 or later
  • github.com/gofiber/fiber2.52.5 or later
  • github.com/gofiber/fiber/v22.52.5 or later
  • github.com/gofiber/fiber/v2/middleware/session2.52.5 or later

Affected products

ProductAffected versionsFixed in
gofiber fiberv < 2.52.52.52.5
github.com/gofiber/fiberGov < 2.52.5, No range specified2.52.5
github.com/gofiber/fiber/v2Gov < 2.52.52.52.5
github.com/gofiber/fiber/v2/middleware/sessionGov < 2.52.52.52.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.