CVE-2024-38826

Medium

Description

Authenticated users can upload specifically crafted files to leak server resources. This behavior can potentially be used to run a denial of service attack against Cloud Controller. The Cloud Foundry project recommends upgrading the following releases: * Upgrade capi release version to 1.194.0 or greater * Upgrade cf-deployment version to v44.1.0 or greater. This includes a patched capi release

SeverityMedium
CVSS5.3
Exploit probability—
ProductCloud Foundry
PublishedNov 11, 2024
First seenNov 11, 2024

How to fix

Update
  • Cloud Foundry Cloud Foundry1.194 or later

Affected products

ProductAffected versionsFixed in
Cloud Foundry Cloud Foundryv < 1.1941.194

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.