CVE-2024-38856

CriticalActively exploited (CISA KEV)

Description

Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through 18.12.14. Users are recommended to upgrade to version 18.12.15, which fixes the issue. Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache OFBiz
PublishedAug 5, 2024
First seenAug 5, 2024
Added to KEVAug 27, 2024

How to fix

CISA required action

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

CISA due date: Sep 17, 2024
Update
  • apache ofbiz18.12.15 or later

Affected products

ProductAffected versionsFixed in
apache ofbizv < 18.12.1518.12.15

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-38856 · Apache OFBiz · Dark Radar