CVE-2024-3931

Low

Description

A vulnerability was found in Totara LMS up to 18.7. It has been rated as problematic. Affected by this issue is some unknown functionality of the file admin/roles/check.php of the component User Selector. The manipulation of the argument ID Number leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 13.46, 14.38, 15.33, 16.27, 17.21 and 18.8 is able to address this issue. It is recommended to upgrade the affected component.

SeverityLow
CVSS3.5
Exploit probability—
ProductTotara
PublishedApr 18, 2024
First seenApr 18, 2024

How to fix

Update
  • totara totara13.46, 14.38, 15.33, 16.27, 17.21, 18.8 or later

Affected products

ProductAffected versionsFixed in
totara totara13.0 ≤ v < 13.46, 14.0 ≤ v < 14.38, 15.0 ≤ v < 15.33, 16.0 ≤ v < 16.27, 17.0 ≤ v < 17.21, 18.0 ≤ v < 18.813.46, 14.38, 15.33, 16.27, 17.21, 18.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.