CVE-2024-39320
Medium
Description
Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, the vulnerability allows an attacker to inject iframes from any domain, bypassing the intended restrictions enforced by the allowed_iframes setting. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.
SeverityMedium
CVSS6.1
Exploit probability—
Product
Discourse
PublishedJul 30, 2024
First seenJul 30, 2024
Weakness typeCWE-74InjectionCWE-1021CWE-1021
How to fix
Update
- discourse discourse3.2.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| discourse discourse | v < 3.2.5, 3.3.0 | 3.2.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.