CVE-2024-39573
High
Description
Potential SSRF in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to cause unsafe RewriteRules to unexpectedly setup URL's to be handled by mod_proxy. Users are recommended to upgrade to version 2.4.60, which fixes this issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Http Server
PublishedJul 1, 2024
First seenJul 1, 2024
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache http_server2.4.60 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache http_server | 2.4.0 ≤ v < 2.4.60 | 2.4.60 |
| netapp ontap | 9 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.