CVE-2024-39863

Medium

Description

Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3, which fixes this issue.

SeverityMedium
CVSS5.4
Exploit probability—
ProductApache Airflow
PublishedJul 17, 2024
First seenJul 17, 2024

How to fix

Update
  • apache airflow2.9.3 or later
  • apache-airflow2.9.3 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.9.32.9.3
apache-airflowPyPIv < 2.9.32.9.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.