CVE-2024-39877
High
Description
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
SeverityHigh
CVSS8.8
Exploit probability—
Product
Apache Airflow
PublishedJul 17, 2024
First seenJul 17, 2024
Weakness typeCWE-94Code injection
How to fix
Update
- apache airflow2.9.3 or later
- apache-airflow2.9.3 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache airflow | 2.4.0 ≤ v < 2.9.3 | 2.9.3 |
| apache-airflowPyPI | 2.4.0 ≤ v < 2.9.3 | 2.9.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.