CVE-2024-39887

Medium

Description

An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. To mitigate this, a new configuration key named DISALLOWED_SQL_FUNCTIONS has been introduced. This key disallows the use of the following PostgreSQL functions: version, query_to_xml, inet_server_addr, and inet_client_addr. Additional functions can be added to this list for increased protection. This issue affects Apache Superset: before 4.0.2. Users are recommended to upgrade to version 4.0.2, which fixes the issue.

SeverityMedium
CVSS4.3
Exploit probability—
ProductApache Superset
PublishedJul 16, 2024
First seenJul 16, 2024
Weakness typeCWE-89SQL injection

How to fix

Update
  • apache superset4.0.2 or later
  • apache-superset4.0.2 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 4.0.24.0.2
apache-supersetPyPIv < 4.0.24.0.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.