CVE-2024-40629

Critical

Description

JumpServer is an open-source Privileged Access Management (PAM) tool that provides DevOps and IT teams with on-demand and secure access to SSH, RDP, Kubernetes, Database and RemoteApp endpoints through a web browser. An attacker can exploit the Ansible playbook to write arbitrary files, leading to remote code execution (RCE) in the Celery container. The Celery container runs as root and has database access, allowing an attacker to steal all secrets for hosts, create a new JumpServer account with admin privileges, or manipulate the database in other ways. This issue has been patched in release versions 3.10.12 and 4.0.0. It is recommended to upgrade the safe versions. There are no known workarounds for this vulnerability.

SeverityCritical
CVSS10.0
Exploit probability—
ProductFit2cloud Jumpserver
PublishedJul 18, 2024
First seenJul 18, 2024

How to fix

Update
  • fit2cloud jumpserver3.10.12 or later

Affected products

ProductAffected versionsFixed in
fit2cloud jumpserver3.0.0 ≤ v < 3.10.123.10.12

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.