CVE-2024-40637
Description
dbt enables data analysts and engineers to transform their data using the same practices that software engineers use to build applications. When a user installs a package in dbt, it has the ability to override macros, materializations, and other core components of dbt. This is by design, as it allows packages to extend and customize dbt's functionality. However, this also means that a malicious package could potentially override these components with harmful code. This issue has been fixed in versions 1.8.0, 1.6.14 and 1.7.14. Users are advised to upgrade. There are no kn own workarounds for this vulnerability. Users updating to either 1.6.14 or 1.7.14 will need to set `flags.require_explicit_package_overrides_for_builtin_materializations: False` in their configuration in `dbt_project.yml`.
How to fix
- getdbt dbt_core1.6.14, 1.7.14 or later
- dbt-core1.6.14, 1.7.14 or later
- getdbt dbt-core1.6.14, 1.7.14 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| getdbt dbt_core | v < 1.6.14, 1.7.0 ≤ v < 1.7.14 | 1.6.14, 1.7.14 |
| dbt-corePyPI | 1.6.0 ≤ v < 1.6.14, 1.7.0 ≤ v < 1.7.14, v < 1.6.14 | 1.6.14, 1.7.14 |
| getdbt dbt-core | 1.6.0 ≤ v < 1.6.14, 1.7.0 ≤ v < 1.7.14 | 1.6.14, 1.7.14 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.