CVE-2024-41132
Medium
Description
ImageSharp is a 2D graphics API. A vulnerability discovered in the ImageSharp library, where the processing of specially crafted files can lead to excessive memory usage in the Gif decoder. The vulnerability is triggered when ImageSharp attempts to process image files that are designed to exploit this flaw. All users are advised to upgrade to v3.1.5 or v2.1.9.
SeverityMedium
CVSS5.3
Exploit probability—
ProductSixlabors Imagesharp
PublishedJul 22, 2024
First seenJul 22, 2024
Weakness typeCWE-789CWE-789
How to fix
Update
- sixlabors imagesharp2.1.9, 3.1.5 or later
- SixLabors.ImageSharp2.1.9, 3.1.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| sixlabors imagesharp | 2.1.0 ≤ v < 2.1.9, 3.1.0 ≤ v < 3.1.5 | 2.1.9, 3.1.5 |
| SixLabors.ImageSharpNuGet | v < 2.1.9, 3.0.0 ≤ v < 3.1.5 | 2.1.9, 3.1.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.