CVE-2024-41169
High
Description
The attacker can use the raft server protocol in an unauthenticated way. The attacker can see the server's resources, including directories and files. This issue affects Apache Zeppelin: from 0.10.1 up to 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue by removing the Cluster Interpreter.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Zeppelin
PublishedJul 12, 2025
First seenJul 12, 2025
Weakness typeCWE-664CWE-664
How to fix
Update
- apache zeppelin0.12.0 or later
- org.apache.zeppelin:zeppelin-interpreter0.12.0 or later
- org.apache.zeppelin:zeppelin-server0.12.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache zeppelin | 0.10.1 ≤ v < 0.12.0 | 0.12.0 |
| org.apache.zeppelin:zeppelin-interpreterMaven | 0.10.1 ≤ v < 0.12.0 | 0.12.0 |
| org.apache.zeppelin:zeppelin-serverMaven | 0.10.1 ≤ v < 0.12.0 | 0.12.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.