CVE-2024-41177

Medium

Description

Incomplete Blacklist to Cross-Site Scripting vulnerability in Apache Zeppelin. This issue affects Apache Zeppelin: before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.

SeverityMedium
CVSS6.1
Exploit probability—
ProductApache Zeppelin
PublishedAug 3, 2025
First seenAug 3, 2025

How to fix

Update
  • apache zeppelin0.12.0 or later
  • org.apache.zeppelin:zeppelin-web0.12.0 or later

Affected products

ProductAffected versionsFixed in
apache zeppelinv < 0.12.00.12.0
org.apache.zeppelin:zeppelin-webMavenv < 0.12.00.12.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.